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GIS TRAINING 
 

 Downloading freely available datasets 
 

 SRTM 30m 

 SRTM90m 

 MODIS Landcover 500m 

 Sentinel 30m 

 GEBCO 

 Earthquake catalog 
 

 
Websites where datasets can be downloaded: 
 

 CGIAR: http://srtm.csi.cgiar.org/ 

 Earth Explorer: https://earthexplorer.usgs.gov/ 

 Google Earth Engine: https://earthengine.google.com/ 

 https://earthquake.usgs.gov/earthquakes/search/ 
 

1. CGIAR 
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2. Earth Explorer (Registration required) 
 

 
 
 
 

3. Google Earth Engine (Registration required) 
 

 
 
MODIS Land Cover Product link: 
https://lpdaac.usgs.gov/dataset_discovery/modis/modis_products_table/mcd12q1 
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4. Glovis Next (Registration required) 
 

 
 
 
 

5. GEBCO 
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 Installation of QGIS software 
Download the OSGeo4W Network Installer for advanced users. This version enables the user to receive 
latest software/plugin updates. 
 
 Installation of QGIS plugins 
Install the following plugins by going to Plugins tab, Manage and Install Plugins…  
 

 OpenLayersPlugin 

 Points2One 

 Digitizing Tools 

 Georeferencer 

 Interpolation 

 Slicer 
 
 Familiarization of QGIS software 

 
Saving a project: 
Projects are saved to preserve the settings made by the user. Always save project before finishing work. 
1. In Project menu, select Save As… 
2. In File name, input project name and browse to the directory where the project will be saved. 
3. Click Save. 
 
Exploring the interface: 
1. Explore contents of each menu: Project, Edit, View, Layer, Settings, Plugins, Vector, Raster, Web, 

Processing, and Help. 
2. Explore toolbars: Project, Map Navigation, Attributes, Digitizing, and Manage Layers. 

 
Defining projection of data frame to Geographic Coordinate System: 

1. In the lower right corner, click on Project Properties button , which is currently set 
to EPSG:3857 (Pseudo Mercator Projection). 

2. In Project Properties dialog, tick on Enable ‘on the fly’ CRS transformation (OTF), layers even in 
different projections can overlay properly.  

3. In Coordinate Reference System, choose WGS 84 to transform the current projection to the 
geographic coordinate system.  It should already register EPSG:4326 (GCS WGS84). 

 
Inputting vector data: 
1. Click Add Vector Layer button . 
2. Browse to directory, select file (e.g. PNG_Geology.TAB). 
3. Click Open. 
 
Converting to another vector format: 
1. Right-click on layer and select Save As… 
2. In Format, select type to save the vector, e.g. ESRI Shapefile. 
3. In File name, input output filename and save in preferred directory. 
4. In CRS, select coordinate system for the layer. 
5. Click OK. 
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Changing vector layer style in QGIS: 
1. To change layer style, right click on the polygon layer and choose Properties>Style. 
2. In the drop down menu, in case the layer only has one type, select default option Single symbol.  
3. In the Fill box, click on Simple fill to enable modification of layer style. 
4. In Symbol layer type, choose Outline: Simple line. 
5. In Color, choose preferred color. 
6. In Pen width, choose preferred line width. 
7. In Pen style, choose preferred line style e.g. solid, dashed, etc. 
8. Click OK to display new style. 
 
In case the layer has more than one type, the user can choose between 2 options to display different 
types:  
1. In the drop-down menu, choose Categorized or Graduated. 
2. In Column, choose attribute field used to display the layer. 
3. In case Graduated is chosen to represent the layer, select Mode of classification and number of 

classes. 
4. Click Classify button. 
5. Click OK to display new style. 
 
In case the user prefers to display the layer with respect to different fields, e.g. magnitude (shape) and 
depth (color) at the same time:  
1. Click Add Vector Layer button  to add the filename, Earthquake.shp. 
2. Right-click on the layer and choose Properties>Style. 
3. In the drop-down menu, choose Graduated. 
4. In Column, choose attribute field (e.g. depth) used to display the layer. 
5. In Color ramp, choose the color graduation scheme to represent variation in depth. 
6. Select Mode of classification and number of classes and click Classify button. 
7. Go back to the first drop-down menu, this time choose Rule-based. 
8. Category range may be customized by double clicking on a range, and defining new range for both 

Label and Filter. 
9. Right-click on one category, select Refine current rule and select Add ranges to rule. 
10. In Column, choose second attribute field (e.g. magnitude) used to display the layer. 
11. Select Mode of classification and number of classes and click Classify button. 
12. Double click on a range to define a new range. 
13. Click OK to go back to the main Style properties. This time, the layer style should be categorized in 

both magnitude and depth. 
14. Click on each symbol to change symbol size to represent magnitude variation. 
 
Displaying vector layer properties: 
1. Right-click layer, click Properties. 
2. Explore different categories. 
3. In General panel, layer source directory and coordinate system can be seen. 
4. In Label panel, the user can display a layer attribute as label. 
5. In Metadata panel, detailed information about the selected layer can be seen, e.g. coordinate system, 

format, resolution (in case raster), etc. 
 
Inputting raster data: 
1. Click Add Raster Layer button . 
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2. Browse to directory, select SRTM DEM file. 
3. Click Open. 

 
Changing raster layer style in QGIS: 
1. To change layer style, right click on the raster layer and choose Properties>Style. 
2. In Render type, select Singleband pseudocolor. 
3. In Color, select preference. 
4. Select Mode of classification and number of classes. 
5. Click Classify button. 
6. To modify range, double click on a range value and input new value.  
7. To make the raster layer transparent, in properties, choose Transparency. 
8. In Global transparency, choose percentage of transparency. 
9. Once a standardized style has been developed, this can be saved and applied to similar raster layers, 

in Style button. 

 
Displaying vector layer properties: 
1. Right-click layer, click Properties. 
2. Explore different categories. 
3. In General panel, layer source directory and coordinate system can be seen. 
4. In Transparency panel, the user can display a raster layer at certain levels of transparency, usually to 

overlay with other raster data. 
5. In Metadata panel, detailed information about the selected layer can be seen, e.g. coordinate system, 

format, resolution (in case raster), etc. 

 
 
EXERCISE 1: Developing exposure database 

One of the main requirements in developing an exposure database is digitizing the locations of buildings, 
critical facilities, and integrating attributes of each structure, e.g. structure type, building usage, building 
population, etc.  In case there are no local base map available, the Google Earth image may be used as 
base layer when digitizing. 
 
Displaying raster base layer: 

In Web menu, click OpenLayers plugin (install if not available), and select Google Maps>Google 
Hybrid or another base layer of preference. 

 
Creating new shapefile layer: 

1. Click New Shapefile Layer button . 
2. Select a shapefile type, e.g. Polygon. 
3. Select coordinate system to use, e.g. Pseudo Mercator, in case you plan to use the Google Earth as 

basemap, or Geographic Coordinate System WGS84 for general mapping, or the coordinate system of 
the basemap being used. 

4. Click OK. 
5. In File name, input filename name e.g. Buildings.shp and browse to the directory where the layer 

will be saved. 
6. Click Save. 
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Enabling snapping in QGIS: 
To append to a digitized line or polygon, enable snapping for accurate connection to the line/polygon. 
This is important especially when you plan to use the line data to convert to a polygon layer or to snap to 
a different layer for seamless connection.  
 
1. In Settings menu, choose Snapping Option. 
2. In Layer selection, choose preferred layer. In this case, the Buildings.shp layer should be clicked or 

activated, and choose Current layer. 
3. In Snap to, choose To vertex. 
4. In Tolerance, choose 10 pixels. When connecting to another line, hovering within 10 pixels from the 

vertex will activate snapping as indicated by a pink cross. 
5. Click OK to return to layer editing. 
 
Editing a shapefile layer in QGIS: 
1. Right click on the line layer and choose Toggle Editing. At this point, a pen icon is overlaid on the layer 

, to indicate that the layer is editable. 

2. Click on Zoom In or Zoom Out button   to zoom in or out of an area. Take note, effective largest 

scale when zooming in should be 1:2,500  . Otherwise, zooming in too much might not 
be able to overlay layers on the raster base map properly. 

3. Click on Pan button  to move around an area. 
4. To start editing, make sure that the layer to be edited is clicked. 

5. Click Add Feature button  (in this case, green polygon icon), and start tracing the buildings. 
6. To end digitizing a polygon, right click on mouse, click OK. 
7. To stop editing a layer, right click on layer and choose Toggle Editing. 
 
Displaying and managing attribute table: 
1. Right-click layer, click Open attribute table. 

2. Click Toggle Editing button  to start editing table. 

3. To add new attribute or field, click on New Field button . 

4. To delete existing attribute or field, click on Delete Field button . 
 
To select particular features only using an expression: 

5. In the attribute table, click Select features using an expression button  . 
6. Double-click on Fields and Values. 
7. Double-click on the attribute field to be considered in the selection. 
8. Double-click on Operators, select preferred operator e.g. ‘=’ equals sign, or ‘>’greater than sign. 
9. Either input category to be selected (use single quotes when selecting string or text attributes) or 

select all unique button in Load values, and double click the category preferred. 
 

Sample expression:  "BuildingType" = ‘Residential’ 
                                     "Population" >  5 
 

After selecting a number of features, the items will be highlighted. In case you wish to display only the 
selected features, click on Show All Features button> Show Selected Features. Selected features can be 
updated by batch: 

1. In the attribute table, click Open field calculator button . 
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2. Tick Update existing field. 
3. In the drop-down menu, select the attribute field to be updated. 
4. In the expression box, input value or expression or geometry (e.g. area), etc. that will be used to 

update the field (use single quotes when selecting string or text attributes). 
 
Determining area and perimeter of a polygon: 
1. In Vector menu, choose Geometry Tools > Export/Add geometry columns. 
2. In Input layer, select polygon layer. 
3. In Calculate using, select preferred projection system to obtain coordinates from. 
4. In Added geom info, save new output point shapefile. 
 
Converting polygon to centroid and obtaining centroid coordinates: 
1. In Vector menu, choose Geometry Tools > Polygon centroids. 
2. In Input layer, select polygon layer. 
3. In Centroids, save new output point shapefile. 
 
To add x and y coordinates of points: 
4. In Vector menu, choose Geometry Tools > Export/Add geometry columns. 
5. In Input layer, select point layer. 
6. In Calculate using, select preferred projection system to obtain coordinates from. 
7. In Added geom info, save new output point shapefile. 

 
Converting polygon to line: 
1. In Vector menu, choose Geometry Tools > Polygons to Lines. 
2. In Input layer, choose polygon layer. 
3. In Polygons from lines, save output shapefile. 
 
Converting line to polygon: 
1. In Vector menu, choose Geometry Tools > Lines to Polygons. 
2. In Input layer, choose line layer. 
3. In Lines from polygons, save output shapefile. 
 
 

EXERCISE 2: Generating a raster surface based on point data 
Interpolation can be used to estimate values in a raster surface given only a limited number of sample 
data, e.g. rainfall, elevation, concentrations, earthquake magnitude, etc. 
 
Displaying table data in csv format: 

1. Click Add Delimited Text Layer button . 
2. Browse csv file (query.csv) to upload in QGIS. 
3. In File format, select CSV. 
4. If a header has been created, the option First record has field names is ticked. 
5. In Geometry definition, tick the option Point coordinates and make sure that X field and Y field is 

correctly defined e.g. Longitude and Latitude, respectively. Point attribute name may be different in 
other data, especially if it uses a projected coordinate system, e.g. Easting in the x direction and 
Northing in the y direction. 
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6. Click OK and choose the coordinates system where the tabular data is based. In case the coordinates 
of the points are based on the Geographic Coordinate System WGS84, select EPSG:4326 (GCS 
WGS84) in CRS dialog box to display the points. For other coordinate systems, the user can browse 

in the Select CRS button . 
 
Converting to another vector format: 
1. Right-click on layer and select Save As… 
2. In Format, select type to save the vector, e.g. ESRI Shapefile. 
3. In File name, save new output in preferred directory. 
4. In CRS, select coordinate system for the layer. 
5. Click OK. 
 
Interpolation: 
1. In Raster menu, choose Interpolation > Interpolation. 
2. In Input box > Vector layers, select the vector layer to be interpolated, usually point data e.g. 

earthquake shapefile. 
3. In Input box > Interpolation attribute, select attribute where interpolation will be based e.g. 

magnitude. Click Add button. 
4. In Output box > Interpolation method, select method, usually IDW. 
5. Click Set to current extent button. 
6. In Output box > Cellsize, input preferred resolution size, make sure to input values based on the 

coordinate system used by the original data (e.g. degrees, meters). Note that 1 degree is 
approximately 111120 meters. 

7. In Output box > Output file, save output raster file. Click OK.  
 
Extracting raster file: 
1. In Raster menu, choose Extraction > Clipper. 
2. In Input file, choose raster layer. 
3. In Output file, save as type GeoTIFF the output shapefile. 
4.    In Clipping mode, select Extent to input coordinates or drag the mouse, or select Mask Layer to 

extract using a predetermined polygon shapefile. 
5.   In case Mask Layer is chosen, select polygon mask, then input preferred resolution size. Take note 

coordinate system used to determine if pixel size should be in meters or degrees. Click OK. 
 
Changing raster layer style in QGIS: 
1. To change layer style, right click on the raster layer and choose Properties>Style. 
2. In Render type, select Singleband pseudocolor. 
3. In Color, select preference. 
4. Select Mode of classification and number of classes. 
5. Click Classify button. 
6. To modify range, double click on a range value and input new value.  
7. To make the raster layer transparent, in properties, choose Transparency. 
8. In Global transparency, choose percentage of transparency. 
9. Once a standardized style has been developed, this can be saved and applied to similar raster layers, 

in Style button. 
 
Generating contour layer: 
1. In Raster menu, choose Extraction > Contour. 
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2. In Input file, choose raster layer. 
3. In Output file, save output shapefile. 
4. In Interval between contour lines, input preferred interval. 
5. Tick Attribute name and select the elevation attribute.  
6. Click OK. 
 
 

EXERCISE 3: Generating a slope surface and contour layer based on freely 
available DEM 
Slope information can be derived from a DEM surface. Slope is usually generated using the projected 
coordinate system (meters). Since the z or elevation data is in meters, the x and y coordinates should also 
be in meters. However, slope can also be derived using the geographic coordinate system, provided that 
the conversion factor, degrees to meters, is provided. 
 
Contours can be generated from any raster surface for better interpretation of raster data. 
 
Inputting raster data: 
1. Click Add Raster Layer button . 
2. Browse to directory, select SRTM DEM or GEBCO file. 
3. Click Open. 
 
Generating slope layer: 
1. In Raster menu, choose Terrain Analysis > Slope. 
2. In Elevation layer, choose a raster layer. 
3. In Output layer, save output shapefile. 
4. In Output format, select GeoTIFF. 
5. In Z factor, input 1 (if using projected system, x & y in meters) or input 111120 (if using geographic 

system, x & y in degrees). Click OK. 
 
Generating contour layer: 
1. In Raster menu, choose Extraction > Contour. 
2. In Input file, choose a raster layer. 
3. In Output file, save output shapefile. 
4. In Interval between contour lines, input preferred interval. 
5. Tick Attribute name and select the elevation attribute.  
6. Click OK. 

 
Raster reclassification: 
Reclassification is done to separate continuous values in a raster surface into specific ranges, for example, 
a slope range of less than 30 degrees is considered low in terms of its potential to generate a landslide, 
while a slope of 30 to 45 is considered high, etc.  
 
1. In Raster menu, choose Slicer > Slicer. 
2. In Input File, choose raster layer. 
3. In Output File, choose output reclassed raster layer. 
4. Tick Add to Raster Layers Panel. 
5. In Step, select Variable.  
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6. Input a preferred range and click Add button. Repeat as required. 
7. Click Slice button to execute. 
 
Raster calculation: 
Raster calculation is usually done to combine values from different rasters for various applications e.g. 
suitability analysis, inundation, etc. The process is similar to using a calculator but on a mtrix level. 
1. In Raster menu, choose Raster calculator. 
2. In Output layer, save output raster file. 
3. In Output format, select preferred format, usually GeoTIFF. 
4. In Output CRS, select layer CRS.  
5. In the expression box, input equation, using one of more raster layers depending on the equation that 

will be used to calculate for the new raster output. Note that raster calculation will be pixel-based. 
Raster layers to be used in the calculation should be based on the same coordinate system. 

 
Converting raster to text file: 
1. In Raster menu, choose Conversion > Translate (Convert Format). 
2. In Input layer, choose a raster layer. 
3. In Output layer, save as type ASCII Gridded XYZ the output shapefile. 
 
Converting raster to vector: 
1. In Processing menu, choose Toolbox  > GRASS GIS > Raster > raster.to.vect. 
2. In Input raster layer, choose raster layer. 
3. In Feature type, choose vector format. 
4. In Vectorize, save output shapefile. 

 
 
EXERCISE 4: Georeferencing an image 
Georeferencing or rectification is a process of relating a raster image from an arbitrary coordinate system 
with spatial locations on the ground using a projection/geographic coordinate system. This can be seen in 
a GIS software, where any location on the map is matched to corresponding ground coordinates e.g. 
longitude/latitude or Easting/Northing in the real world.  
 
Analog/paper maps e.g. topographic maps, land cover maps, etc. are converted to digital format by first 
scanning, and then georeferencing. The process usually involves simple matching of the tick marks 
indicating specific locations on the ground. However, some maps especially older ones with low mapping 
quality may rarely match correctly. Hence, rubbersheeting, a process wherein a layer is distorted to 
seamlessly match with other spatial data, may be implemented. 
 
Georeferencing an image: 
1. In Raster menu, choose Georeferencer > Georeferencer. 
2. Click Add Raster Layer button  (e.g. PNG_Soil Map 2.jpg). 
3. Click Transformation Settings button , leave default settings and save output file.  

4. Click Add Point button  to add new point. 
5. In the Enter map coordinates, either input coordinates for x and y or use map, From map canvas, 

and match the location on another existing map or using the Google Earth basemap. Note, when 
using Google Earth images, set Pseudo Mercator as coordinate system in Transformation Settings > 
Target SRS. 
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6. Click Delete Point button  to delete existing point. 

7. Click Move GCP Point button  to move existing point. 
8. When done (choosing at least 4 GCPs), select Start Georeferencing button . 
 
 

EXERCISE 5: Generating land cover layer 
Detailed land cover maps may be generated using high resolution images or the Google Earth base map 
in QGIS. Merging of different layers may be necessary, for example road and river network to the land 
cover layer, which involves different geoprocessing techniques. 
 
Converting point to polygon shapefile format: 
To define an exact region, a separate table containing the coordinates of the polygon to be defined can 
be prepared first e.g. excel, in notepad, etc. in the following order: ID, X, Y. 
 
1. In Vector menu, select Points2One (install plugin if not available). 
2. In Input vector layer, select the table data containing coordinates of the domain, and tick Create 

polygons. 
3. Tick Sort vertices by, and choose ID. Make sure that the order of points in the shapefile/text format 

should be in the right order, otherwise, resulting polygon will be crisscrossed. 
4. Browse to preferred directory and save output shapefile. 
5. Tick option Add result to canvas. 
6. Click OK to display the polygon.  
 
Enabling snapping in QGIS: 
To append to a digitized line, enable snapping for accurate connection to the line. This is important 
especially when you plan to use the line data to convert to a polygon layer or to snap to a different layer 
for seamless connection.  
 
1. In Settings menu, choose Snapping Option. 
2. In Layer selection, choose preferred layer. In this case, the shoreline layer should be clicked or 

activated, and choose Current layer. 
3. In Snap to, choose To vertex. 
4. In Tolerance, choose 10 pixels. When connecting to another line, hovering within 10 pixels from the 

vertex will activate snapping as indicated by a pink cross. 
5. Click OK to return to layer editing. 
 
Editing a shapefile layer in QGIS: 
1. Right click on the line layer and choose Toggle Editing. At this point, a pen icon is overlaid on the layer 

, to indicate that the layer is editable. 

2. Click on Zoom In or Zoom Out button   to zoom in or out of an area. Take note, effective largest 

scale when zooming in should be 1:2,500  . Otherwise, zooming in too much might not 
be able to overlay layers on the raster base map properly. 

3. Click on Pan button  to move around an area. 
4. To start editing, make sure that the layer to be edited is clicked. 
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Usually, it is recommended to include in the attribute table which kinds of information is required in the 
layer before digitizing, e.g. type, so that a feature can be updated immediately.   
5. Right-click layer, click Open attribute table. 

6. Click Toggle Editing button  to start editing table. 

7. To add new attribute or field, click on New Field button . 
 
Start digitizing land cover features. 

8. Click Add Feature button   (in this case, green polygon icon), and start tracing the shoreline. 
9. To end digitizing a polygon, right click on mouse, click OK. 
10. To stop editing a layer, right click on the layer and choose Toggle Editing. 
 
Splitting a polygon layer using a cutter line: 
Prepare the cutter line: 
1. Create a new line shapefile which will serve as your cutter line.  
2. Trace boundaries on the rectified raster map layer. Make sure that starting and end vertex are 

located outside the main polygon to be divided. 
 

To divide the main polygon: 
3. Select the line layer and select the particular line that will be used to cut it using the Select Features 

button . 
4. Select the polygon layer, right-click to select Toggle editing and select the main polygon to be cut 

using the Select Features button . 

5. Click the Split selected features with selected line from another feature button . 
6. In splitter layer, select the line layer that will be used to cut the polygon. 
 
Updating attribute data: 
At this point, several polygons have been defined to represent a particular land cover type. However, 
there is no indication yet which type it represents, hence the attribute table needs to be updated. This 
also enables the user to display land cover types as labels in the interface. 
 
Buffering: 
Buffering is implemented to define an area within a given proximity. For example, digitizing a road 
network using the line vector cannot simulate the actual road extent. However, buffering it according to 
its width on the ground can provide a more realistic idea how much area the road covers. Buffering may 
be implemented using a fixed buffer or varying buffer distances. The latter may be used for example in a 
road network to differentiate it according to types based on size e.g. national roads, secondary roads, 
village roads, tracks, etc. 
 
To use a fixed buffer distance: 
1. In Vector menu, choose Geoprocessing Tools > Fixed distance buffer. 
2. In Input layer, select layer to be buffered. 
3. In Distance, input distance from feature to be buffered, make sure to input values based on the 

coordinate system used by the original data (e.g. degrees, meters). Click 
4.  Usually, Dissolve result is ticked to smoothly combine intersections. 
5. In Buffer, save output shapefile. Click Run. 
 
To use varying buffer distances: 
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1. In Vector menu, choose Geoprocessing Tools > Variable distance buffer. 
2. In Input layer, select layer to be buffered. 
3. In Distance, input distance from feature to be buffered, make sure to input values based on the 

coordinate system used by the original data (e.g. degrees, meters). Click Run. 
4. Usually, Dissolve result is ticked to smoothly combine intersections. 
5. In Buffer, save output shapefile. Click Run. 
 
Clipping a vector data: 
1. In Vector menu, choose Geoprocessing Tools > Clip. 
2. In Input layer, select layer to be clipped. 
3. In Clip layer, select layer used to clip. 
4. In Clipped, save output shapefile. Click Run. 
 
Erasing features in a vector data: 
For example, when integrating the road shapefile with the land cover shapefile, the area where the road 
intersects the land cover will have to be erased in the land cover layer first, before merging both files to 
ensure no duplicates in the final merged output.  
 
1. In Vector menu, choose Geoprocessing Tools > Difference. 
2. In Input layer, select layer to be erased. 
3. In Difference layer, select layer used to erase. 
4. In Difference, save output shapefile. Click Run. 
 
Dissolving attributes: 
Dissolving is done to combine similar types within the same layer. 
1. In Vector menu, choose Geoprocessing Tools > Dissolve. 
2. In Input layer, select polygon layer to dissolve. 
3. To dissolve all, tick Dissolve all.  

To dissolve based only on particular fields, untick Dissolve all, in Unselected box, select attribute to 
use for dissolving, click right arrow. 

4. In Dissolved, save output shapefile. Click Run. 
Merging vector data: 
1. In Vector menu, choose Data Management Tools > Merge vector layers. 
2. In Layers to merge, select layers to be merged. 
3. In Merged, save output shapefile. Click Run. 
 
Reprojecting a vector layer: 
Sometimes the layer being digitized is based on a specific coordinate system, e.g. Pseudo Mercator or 
UTM system, and it is necessary to project it to a coomon coordinate system to combine with other 
spatial data baesed a different system. 
1. Right-click on layer, click Save As… 
2. In File name, save output shapefile. 
3. In CRS, choose preferred coordinate system to reproject to. Click OK. 
 
Converting vector to raster: 
In some applications, it is necessary to provide the raster version of a vector data.  
1. In Raster menu, choose Conversion > Rasterize (Vector to Raster). 
2. In Input file, choose polygon layer. 
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3. In Attribute field, choose the field to base the raster data from (should be numbers, not text). 
4. Tick Raster resolution map units per pixel, make sure to input values based on the coordinate 

system used by the original data (e.g. degrees, meters). Click OK. 
 
 
 Layouting a map 
 

1. In File menu, select New Print Composer. 

2. In Layout menu, select Add Map or click Add new map button . 

3. To move map, in Layout menu, select Move Item or click on Select/Move Item button . 
4. To move map content, in Layout menu, select Move Content  or click on Move Item content 

button . 

5. To add legend, in Layout menu, select Add Legend or click on Add new legend button . 
6. To customize legend, click on the legend, on the right hand side panel, in Item properties/Legend, 

input legend title, untick Auto update, then re-order legend items using the up and down arrows, 

add/delete items using the plus and minus signs, rename the legend item by clicking on  
button, fonts, frame and background color. 

7. To add scale bar, in Layout menu, select Add Scalebar or click on Add new scalebar button  . 
8. To customize scalebar, click on the scalebar, on the right hand side panel, in Item 

properties/Scalebar, select preferred style, scale units, label for units, segment, display, fonts and 
colors, frame and background color. 

9. To add north arrow, in Layout menu, select Add Arrow or click on Add Arrow button . 
10. To customize arrow, click on the arrow, on the right hand side panel, in Item properties/Arrow, 

select preferred style, frame and background color. Otherwise, adding north arrow can be done 
using the add image function and selecting preferred SVG icon, as in the following step. 

11. To add image, in Layout menu, select Add Image or click on Add image button . 
12. On the right hand side panel, in Item properties/Picture, select image source, preferred style, 

frame and background color. 

13. To add label, in Layout menu, select Add Label or click on Add new label button . 
14. To customize label, click on the label, on the right hand side panel, in Item properties/Label, input 

text, select preferred style, frame and background color. 
15. To add attribute table, in Layout menu, select Add Attribute Table or select Add attribute table 

button . 
16. To customize attribute table, click on the attribute table, on the right hand side panel, in Item 

properties/Attribute table, select layer to display attribute table, preferred style, fonts and text 
styling, frame and background color. 

17. Click on the map, on the right hand side panel, in Composition tab, select preferred page size and 
resolution size. 

18. In Item properties/Map1, select preferred scale. Click Update preview button to refresh. 
19. To add grid, in Item properties, click on plus sign button. Select preferred grid type, coordinate 

system, x and y interval, frame style, coordinate parameters, frame color, and background color. 
 


